PHP 5.5+ required.